Android studio 解决 Error:Failed to open zip file. Gradle’s dependency cache may be corrupt

2018年4月22日08:59:21 4 134 views

关于java的东西都贼烦,每次装Android不是这样问题就是那样问题。我建议熟练后还是用自己习惯的版本,这次我新电脑下载的官方最新版。

项目编译后,出现以下问题:

Error:Failed to open zip file.

Gradle's dependency cache may be corrupt (this sometimes occurs after a network connection timeout.)

Re-download dependencies and sync project (requires network)

Re-download dependencies and sync project (requires network)

一看这问题就是zip解压失败,接着下面提示Gradle's dependency cache may be corrupt:Gradle的依赖缓存可能是损坏的。到这里大家应该明白,as出现这样的问题是怎么导致的了吧,文件损坏。

我们要导入别人写好的工程时,一般不需要更改什么,as智能判断会提示我们是否需要对build gradle setting之类的文件进行修改。针对gradle个版本工具来说,如果不选择更新直接原来的Gradle Version中的Gradle工具,再加上.gradle库中没用该版本时,as会创建这样的库,有时候这样的库会下载不完整,导致上面的问题。

没关系,as创建了这个路径和文件,只是文件下载不完整呗,手动下载替换掉就行

1、下载 gradle

下载地址很简单,以 下载gradle-4.4-all.zip为例子

不要去网上找这样那样的网站下载gradle工具了。浏览器输入以下链接快速下载:

    services.gradle.org/distributions/gradle-4.4-all.zip

想要下载其他版本只要更改gradle-4.4-all.zip 版本号。已有的版本号有

 gradle-4.4-all.zip
    gradle-3.2-all.zip>
gradle-2.14-all.zip>
以gradle-4.4-all.zip为例子,下载完成后替换 C:\Users\Administrator\.gradle\wrapper\dists\
gradle-4.4-all\9br9xq1tocpiv8o6njlyu5op1中对应的gradle-4.4-all.zip文件。
重新编译as解压文件就不会报错了。正确解压后的的文件如下图所示:
Android studio 解决 Error:Failed to open zip file. Gradle's dependency cache may be corrupt
当然,的工程中的一些配置也要注意Android studio 解决 Error:Failed to open zip file. Gradle's dependency cache may be corrupt

这样我们导入的工程会自动提示更改gradle版本,如官方更新出新的gradle版本,建议更新。导入的工程gradle版本低于库中的版本,as就会提示更新到库中最新版本,选择update就行,这样gradle-wapper.properties文件中的路径就是自己.gradle中最高的版本,不会出现错误。

  • 我的微信
  • 这是我的微信扫一扫
  • weinxin
  • 我的支付宝红包
  • 支付宝红包扫一扫打赏
  • weinxin

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:4   其中:访客  2   博主  2

    • avatar godaddy优惠码 1

      朋友 交换链接吗